8.1 Supported Java Versions

Jasper requires at least Java 2 to run. Except under Windows the full development kit, not just the JRE, is needed. Jasper does not work with Visual J++ or Visual Café. Unless indicated otherwise, you can download the JDK from http://java.sun.com.

Except where indicated, Jasper is supported for Java 1.5 or later.

For some platforms, Jasper is only supported under the following conditions:

Mac OS X
Using Jasper from Java may require that DYLD_LIBRARY_PATH be set up so that Java can find the SICStus runtime library. That is, you may need to set DYLD_LIBRARY_PATH to the location of the SICStus runtime libsprt4-2-3.dylib.

Note that Java 1.6 is not available in a 32-bit version on all versions of Mac OS X.

Send feedback on this subject.